Open Source Adapted Bicycle Pedal Comes to the Rescue
Accessibility has always been important to designers of open source software. Now that open source has come to design, that's more true than ever, as demonstrated with this open source bicycle
Linux Action Show to End Eleven-Year Run at LFNW
Six more episodes before the popular Linux podcast, Linux Action Show, ends its nearly 11-year run in a live broadcast from LinuxFest Northwest.


Jupiter Broadcasting's long-running
Dealing With Real-Life, Everyday Security Threats
No one has ever been shot by a hacker who was breaking into their computer through the Internet. Not so for thieves coming in through the back door.

Roblimo's Hideaway

I wrote a piece
Four Things a New Linux User Should Know
When you move from "that other operating system" to Linux, you're going to find that in most ways you'll be in familiar territory. However, that's not always the case. We sometimes do things a little differently
The Future of Desktop Ubuntu
With all the changes happening at Canonical, you might wonder what this means for the future of desktop Ubuntu, besides the return to the GNOME desktop.

There hasn't been this much news about a single Linux distro
Libreboot Reorganizes: Seeks to Make Amends
It appears the people developing Libreboot have done some of the hard work necessary to fix potentially toxic personal dynamics after last year's controversy, when the project removed itself from the
It's Windows Time in Linux Land Again
Using Windows. What a horrible thing to ask a Linux user to do.
November 12th, 2015

Six WordPress Plugins Vulnerable

In the same week that we learned from W3Techs that the popular open source content management system (CMS) WordPress now powers a full 25 percent of all sites on the web, we learn that six popular WordPress plugins contain serious security vulnerabilities. The later news comes to us by way of security firm Wordfence, which specializes in WordPress security and develops the Wordfence security plugin for the platform.

WordPress logoThis news isn’t surprising, nor is it cause for alarm. Because WordPress is by far the most popular content management platform on the web, it’s an obvious target for hackers, and third party plugins are the most obvious way inside. However, the folks at Automattic, which develops the platform, have proven themselves to be diligent at finding vulnerabilities and keeping them patched.

Third party plugins that are under active development are also generally considered safe, if a little less so, as Automattic also has solid processes in place to deal with plugins that are found to be vulnerable. In today’s announcement, all six plugins involved have already been fixed and all website publishers using them need do is upgrade to the latest versions through the “Plugins>Installed Plugins” tab in their sites’ back end.

According to Wordfence, the following plugins are affected and need to be immediately updated:

Fast Secure Contact Form (over 400,000 active installs): Versions 4.0.37 and earlier of this plugin contain an XSS vulnerability that was made public on October 27th. This was fixed in version 4.0.38.

Bulletproof Security (over 100,000 active installs): Versions .52.4 contains a XSS vulnerability that was made public two weeks ago. Latest version available has been fixed

Blubrry PowerPress (50,000+ active installs) Versions 6.0.4 and earlier of this podcasting plugin contain an XSS vulnerability publicly announced on October 27th — evidently the same vulnerability as Secure Contact Form. Latest version available has been fixed.

Form Manager (30,000+ active installs): Versions 1.7.2 and earlier contain an unauthenticated remote command execution (RCE) vulnerability that was made public on October 23rd and fixed in version 1.7.3.

WordPress Files Upload (10,000+ active installs): Version 3.4.0 and earlier of this plugin allowed a malicious executable file to be uploaded and executed. Fixed in version 3.4.1.

Crony Cronjob Manager (2,000+ active installs) Versions 0.4.4 and earlier of this plugin contain an XSS and CSRF vulnerability that was fixed fifteen days ago.

Any WordPress sites using these plugins are urged to update immediately. As these vulnerabilities are now public knowledge, the bad guys are certainly looking for them.

Help keep FOSS Force strong. If you like this article, become a subscriber.

The following two tabs change content below.
Christine Hall has been a journalist since 1971. In 2001, she began writing a weekly consumer computer column and started covering Linux and FOSS in 2002 after making the switch to GNU/Linux. Follow her on Twitter: @BrideOfLinux

Latest posts by Christine Hall (see all)

3 comments to Six WordPress Plugins Vulnerable